Back to overview
Downtime

Infrastructure provider experienced major service disruption

May 19, 2026 at 10:18pm UTC
Affected services
api.humandesignapi.nl/health

Resolved
May 20, 2026 at 1:41am UTC

The major service disruption at our infrastructure provider has been resolved and all services are back up and running.

Created
May 19, 2026 at 10:18pm UTC

Our infrastructure provider is experiencing a major service distruption due to and error in their upstream cloud service. This page will be updated as soon as more information becomes available. See report: https://status.railway.com/incident/I23M92U0